Startseite Foren Programmierung und Szenen HomeKit und iOs 9 – Verbindung bricht ab und lässt sich nicht mehr herstellen

Ansicht von 3 Beiträgen - 1 bis 3 (von insgesamt 3)
 nonam188 
Teilnehmer

Themen: 2

Antworten: 4

Oktober 20, 2015 um 7:27 pm

Hallo leute

ich verwende einen Raspberry Pi 2 als z-wave-server
das homekit-modul hab ich installier und auch problemlos getestet

mein problem:
nach unterschiedlich langer zeit sagt mein iphone dass das accassorie, allso der raspi, nicht verbunden ist…
es muss am homekit-modul liegen
alles weitere funktioniert
im log kann ich nichts finden, zeigt nur die lezten on/off switch die noch funktioniert haben
das selbe problem gibts auch wenn ich mich mit dem iphone neu ins wlan einlogge

die verbindung lässt sich erst wieder herstellen wenn ich das homekit-modul entferne, wieder hinzufüge und neu verbinde

habt ihr einen tipp, eine idee was es sein könnte oder vielleicht sogar eine lösung?

mfg nonam

 Gabriel 
Teilnehmer

Themen: 3

Antworten: 38

Oktober 23, 2015 um 1:19 pm

Welche Z-Way-Version hast du im Moment installiert? Es gab nämlich zuletzt kleine Bugs im HomeKit-Modul bzw. Änderungen durch iOS9 die genau dazu geführt haben. Theoretisch kannst du die aktuellste HomeKit-Modul JavaScript Datei auf GitHub herunterladen und gegen die aktuelle austauschen – hat z.B. bei mir auch geholfen.

Download

Einfach copy&paste im Editor und als „index.js“ speichern. Auf dem Raspberry muss sie dann gegen die aktuelle unter folgendem Pfad ersetzt werden:

/opt/z-way-server/automation/modules/HomeKitGate/

Ein Backup der alten empfiehlt sich natürlich! 🙂

 nonam188 
Teilnehmer

Themen: 2

Antworten: 4

Oktober 28, 2015 um 6:54 pm

ich verwende die 2.1.1

hab jetzt mal deinen link versucht
das selbe problem besteht weiterhin…

auch die logfile gibt keine hinweise

ich bin ratlos
der rest funktioniert eiwandfrei 🙂

Ansicht von 3 Beiträgen - 1 bis 3 (von insgesamt 3)

Du musst angemeldet sein, um auf dieses Thema antworten zu können.