AnwendungenNewsPresseTutorialsVideos
Img

11 Kommentare

  • Brain
    November 22, 2015 um 11:52 am Uhr

    Hallo und vielen Dank für die Beschreibung. Ich versuche bereits seit einiger Zeit meine POPP KFOB zu verbinden und eine erstellte LUA Szene welche meinen Fenster/Türkontakte scharf schaltet (Alarm ON/Off) zu aktivieren, doch leider bis heute ohne Erfolg.
    Es scheint so, als ob das HC2 keinen Tastendruck der KFOB erkennt. Habt Ihr eine Idee was ich falsch mache?
    Die Anleitung siehe oben habe ich schritt für schritt verfolgt und die entsprechenden Daten so hinterlegt.

    Im Debug erscheint immer folgendes:
    [DEBUG] 11:46:01: unknown sceneID:
    [DEBUG] 11:46:01: nil:
    [DEBUG] 11:46:01: nil:

    Folgende LUA Szene verwende ich:
    –[[
    %% properties
    104 ceneActivation
    %% globals
    –]]

    local RemoteID = 104
    local YYY = 21 — ID der Szene, testszene für Tastendruck 1
    local QQQ = 13 — ID der Szene
    local WWW = 9 — ID der Szene
    local EEE = 11 — ID der Szene

    if ( tonumber(fibaro:getValue(RemoteID, „sceneActivation“)) == 11)
    then
    fibaro:startScene(YYY);
    end

    if ( tonumber(fibaro:getValue(RemoteID, „sceneActivation“)) == 31)
    then
    fibaro:startScene(QQQ);
    end

    if ( tonumber(fibaro:getValue(RemoteID, „sceneActivation“)) == 21)
    then
    fibaro:startScene(WWW);
    end

    if ( tonumber(fibaro:getValue(RemoteID, „sceneActivation“)) == 41)
    then
    fibaro:startScene(EEE);
    end
    fibaro:debug(„Unknown sceneID: „)
    fibaro:debug(name)
    fibaro:debug(fibaro:getValue(RemoteID, „sceneActivation“))

    • Chris
      November 24, 2015 um 9:49 am Uhr

      Hallo,

      – hast du in den Assoziationsgruppen die Verknüpfung zum HC2 gesetzt wie oben beschrieben?
      – hast du nach dem Eintragen der Parameter die KFOB gewecket (alle 4 Tasten drücken dann kurz Taste 2) – so das alle Daten übertragen werden?

      Versuch mal folgendes LUA Script:

      –[[
      %% properties
      540 sceneActivation
      %% globals
      –]]

      local tasterID = 540
      local test = (fibaro:getValue(tasterID, „sceneActivation“));

      print(‚es wurde gedrückt: ‚..test);

      >>> Die ID 540 ist an beiden Stellen natürlich durch die ID deiner KFOB zu ersetzen.

      • Brain
        November 24, 2015 um 3:50 pm Uhr

        Hallo Chris,

        ich bin die oben genannte Anleitung mehrfach durchgegangen und habe Fehler gesucht, doch leider ohne Erfolg. In den Ass. Gruppen 1,2,3,4,5 habe ich das HC2 hinterlegt und anschließend die KFOB im Mgn Mode und Taste 2 versetzt.
        Ich probiere gleich einmal dein Script aus und werde berichten.

        Danke vorab schon einmal.

        • Brain
          November 24, 2015 um 8:43 pm Uhr

          Hallo Chris,

          ich habe das Skript mal abgesetzt. bei einem Tastendruck erscheint leider keine print ausgabe!
          Anbei noch einmal meine Daten vom HC2, das Skript ist ja bereits oben abgebildet.

          associations group:
          EndPoint0 S M Devices list
          Group1 x x Home Center 2
          Group2 x x Home Center 2
          Group3 x x Home Center 2
          Group4 x x Home Center 2
          Group5 x x Home Center 2

          Parameter:

          1 0
          2 0
          11 4
          12 4
          13 4
          14 4

          Ich habe bereits verschiedene Fernbedienungen ausprobiert, es scheint sich immer das gleiche Bild, die Tasten der KFOB werden nicht erkannt.

          Vielen Dank für die Hilfe.

  • Chris
    November 25, 2015 um 11:43 am Uhr

    Mach mal folgendes. Klick mal im Gateway auf Modul löschen (Exkludieren) Dann drücke kurz alle 4 Tasten am KFOB gleichzeitig (LED Blinkt) dann die 1 (links oben)
    Jetzt sollte es ordentlich resetet sein.

    Nun: Gateway auf Modul hinzufügen (Include) dann für 1 Sekunde die Taste 2 drücken (oben rechts) Jetzt sollte es inkludiert sein.
    Dann Parameter setzen und danach alle 4 Tasten (Management Mode) und die Taste 2 (oben rechts)

    Danach sollte in der Szene was ankommen. Achte darauf das die ID im Script an beiden Stellen geändert wurde!

    • Brain
      Dezember 3, 2015 um 10:29 pm Uhr

      Hi Chris,

      ich habe jetzt einmal wieder Zeit gefunden zum Spielen, doch leider auch hier ohne Erfolg. Die FB scheint nicht mit dem HC2 zu kommunizieren.
      Ich habe gerade mal versucht eine grafische Szene zu erstellen mit der KFOB doch leider kann ich nicht, wie bei dir, die Szeneaktivierung ID 11 (günes Feld) eingeben. Ich habe zwar das Feld, kann in dieses aber nichts schreiben/ hinterlegen, Szeneaktivierung steht bei mir auch nicht drin. Was mache ich falsch?

      LG Daniel

      • Brain
        Dezember 4, 2015 um 6:58 am Uhr

        Hallo Chris,

        noch eine Frage nebenbei, nicht dass ich hier bereits etwas falsch gemacht habe. Wird die KFOB im Sekundärcontroller-Modus oder im Primärcontroller-Modus verwendet? ich nutze den Sekundärcontroller-Modus.

        • Chris
          Dezember 4, 2015 um 9:41 am Uhr

          Hi,
          am besten du machst im Forum mal ein neues Thema auf. Dort kannst du auch Bilder wie Screenshots hochladen. Das wäre sehr hilfreich wenn du mal ein Bild von der Blockszene hochlädst sowie von den erweiterten Einstellungen deines KFOB

          http://www.zwave.de/forum/

          Mfg Chris

          • Jochen
            Oktober 15, 2016 um 10:44 pm Uhr

            Hallo Chris,

            ich habe das gleiche Verhalten und habe alle Deine Schritte mehrfach durchgeführt. Ich verwende die Version 4.100 des HC2. Gibt es inzwischen noch eine andere Lösung?

            MfG
            Jochen

  • Bastian
    Juli 8, 2016 um 10:57 pm Uhr

    Hallo,
    gut zu wissen, dass ich nicht der einzige bin, der mit dem WALL-C gekämpft hat. Jedoch ist mein Ergebnis ein wenig anders. Mittlerweile gibt es für den WALL-C auch ein Template, so dass die Einbindung ein wenig einfacher ist. Unter anderem auch mit direkter Assoziation von Geräten.
    MfG
    Bastian

    • André
      November 13, 2016 um 9:32 pm Uhr

      Bin auch gerade auf die Anleitung hier gestossen und komme nicht weiter 🙁
      Ich wollte erst mal nur eine grafische Szene ausprobieren um alles zu testen. Der Taster ist bei mir im Hobbyraum und auch dort aufgelistet. Wenn ich aber bei devices im Hobbyraum schaue, zeigt es den Schalter gar nicht an 🙁
      Need help 🙂

      Danke u. Gruß

      André

Schreibe einen Kommentar